Problem create new project after installation


#1

I received good quality support via email:

I think the problem is that for some reason the groups were not properly applied (may be a bug in the pam module). If it is not asking too much, try to execute this directly on the database:

$ sudo -u postgres psql serverboards
serverboards=# insert into auth_user_group (user_id, group_id) values (1,1);
serverboards=# insert into auth_user_group (user_id, group_id) values (1,2);
serverboards=# \q

This should ensure that the first user (whoever it was) is part of the user and admin groups.

I already added the bug to our jira, and will release a bugfixed version soon.

Now welcome screen looks way better and I can manage it all!


Tips and wizard to give a hand on configuring Serverboards 17.10
#2

Happy to know it helped!

As always if you find any other problem, just open a new thread at the forums!

:slight_smile:


#3

Hi,

I have a problem like this, after finished installation and did not figure out of create project.

image

I have tried your solution as below but there is still show the same.

$ sudo -u postgres psql serverboards
serverboards=# insert into auth_user_group (user_id, group_id) values (1,1);
serverboards=# insert into auth_user_group (user_id, group_id) values (1,2);
serverboards=# \q

Could you please advise?


#4

Did you log out and in again?

If you did, can you send me the contents of the auth_user and auth_group tables?

select * from auth_user;
select * from auth_group;

Another option I’m thinking may work (if you are using PAM auth) is adding a serverboards_admin group to the system, and then adding the user to that group:

$ addgroup serverboards-admin
$ adduser myuser serverbards-admin

And log out and in again.

In the next version, 18.01, all this should be easier; you can try the unstable channel (https://serverboards.io/downloads/unstable). Hope to release it next tuesday.

Regards,
David.

Update: Changed wrong serverboards_admin to serverboards-admin.


#5

Hi,

Yes, I did and please find below auth contents

image


#6

I don’t know what could be happening. I guess you are trying to use Serverboards as tola, right?

What is the installed version? (apt show serverboards).

With the proper permissions a yellow plus button (+) should be available at the bottom right corner that lets you add projects.

Can you send me by email a database dump? I will try to install the same version on a VM and check whats going on.


#7

Hi,

thanks for the access to your server, I could check what is wrong, but I need you to check if it works now.

First try to fix, not this time, but useful information for others:

The user was indeed not in the admin group, I added it with the command line:

s10s user add tola to admin

But this does not work when the user comes from PAM. I may change that so that groups on the database are always added to the PAM groups.

Final fix

Sorry, my bad, I gave you wrong instructions, was not serverboards_admin but serverboards-admin.

I updated the /etc/group file with the proper name.

Can you check if you have access to all the functionalities? (I checked as root and I had).

Regards,
David.


#8

Hi,

Thank you so much for your quick assistant and fixed by did access to my server and I got your solution above. Now I can create the project and other functions are working well.

Again, Thank you :slight_smile:


Community Chat

Join the conversation real time on our Matrix chat room. No need for clients when you connect using Riot.im.